Posts by matzundfritz

    Servus Thomas,


    vielleicht liegts daran dass ich bisher beim Bildimport in Imabas meine Originalbilder in die vorbreitete Volumes verschoben habe. Die Volumes sind auf DVD-Größe begrenzt und können zur Sicherung außer dem Backup noch zusätzlich auf DVD gesichert werden.
    D.h., ich lege auf meiner Platte eine Ordnerstruktur an und dann fange ich an die Ordner zufüllen bis die eingestellte Begrenzung in Imabas greift.
    Und irgendwie passt die vorgeschlagene Vorgehensweise nicht so ganz in mein "Imabasbild"!
    Oder habe ich da vielleicht ein "falsches Bild"! :?:

    Freunde von Imabas,


    ich lese folgende Dinge!


    • Quote

      Die Bilddaten bleiben im Dateisystem und sind ohne Datenbank verfügbar (zu lesen auf der Homepage)


    • Quote

      Bilder werden als externe Referenz gespeichert Dies ist das bevorzugte Verfahren von Imabas. Die Pfadangaben werden ohne Verwendung von Volumes direkt gespeichert, oder über Virtuelle Verzeichnisse adressiert. (zu lesen in der Benutzerhilfe)



    Letzteres wird mir bei der Erstellung einer SQL-Datenbank vorgeschlagen und ist voreingestellt!


    Frage! Wird die Strategie mit den Volumes nicht mehr verfolgt? :a015:


    Ich bin drauf gekommen, bei Überlegungen wie ich meine Bilder für die Zukunft auf dem Server verwalte und wie ich die Sicherungen / Backups bewwerkstellige!

    :smile2: ... s'geht!


    Ich habe Zugriff!


    Zwei Dinge habe ich verändert zu gestern Abend.
    Das eine, ... :oops: ... jetzt die richtige DB vorgewählt!
    Das zweite, ... in der Konfigurationsdatei vom Server (my.cnf) gibt es ein Eintrag,

    Code
    1. bind-address = 127.0.0.1

    Ich habe hier die IP von meinem Server eingetragen und, ... Verbindung! :nicken:


    So, und jetzt wird fleißig gefüllt.
    Eine Übernahme von Firebird zu SQL geht ja, ... gibts hier ja einen Thread.
    Jetzt muß ich noch ein paar grundlegende Einstellungen rauskriegen und dann ... alles wird gut! :-)

    oh, ... sehr schön! Da ist ja richtig Leben drin! :-)
    Also ich will mal in meiner Mittagspause ein paar Antworten geben.


    • die beiden Tools "Administrator" und "Query Browser" habe ich auf dem Server installiert
    • erstellt habe ich die DB allerdings in der Konsole (mit
      Code
      1. create "datenbankname"

      ...)

    • Zugriff auf die DB von einem anderen Rechner, ... muß ich noch prüfen! Bisher habe ich immer direkt auf dem Server bzw. auf dem WinXP-Client gearbeitet um alles einzustellen. Allerdings die normalen gegenseitigen Zugriffe im Netzwerk (Server <--> Client) auf die erstellten Freigaben funktionieren ja.

    Da fällt mir ein, ... die DB wird ja auf dem Server an einem bestimmtne Ort (im Linuxdateiensystem, /var/...) gespeichert. :a015: Den Ordner habe ich im Sambasystem nocht nicht freigegeben!!! Könnte hier der Fehler liegen??? :?:

    • Wie geschrieben arbeite ich ja mit fester IP. Daher habe ich natürlich auch schon die feste IP vom Server verwendet, ... leider ohne Erfolg! :c090:

    @ moguay

    Quote

    der allgemeine Remote-Zugriff ist aktiv, da sonst nicht diese Rückmeldung von mySQL kommen würde

    Was für ein Remote-Zugriff meinst du damit?

    Quote

    sieht danach aus, dass root nur Zugriff von "localhost" aus hat, was in dem Fall dein Server wäre; zum Testen(!) kannst du den Host von root mal auf "%" stellen

    Das kapier ich nicht ganz! Liegt wahrscheinlich an dem nicht vorhandenen Grundwissen!

    Quote

    ich empfehle unbedingt einen eigenen Nutzer für die Imabas-Datenbanken anzulegen und nicht unbedingt root zu verwenden.

    Ich denke du meinst einen Nutzer in den Administrationstool für die DB erstellen!?

    Freunde von Imabas,


    nachdem ich nun endlich Zeit gefunden habe um mich ein wenig mit SQL zu befassen, habe ich habe mir einen kleinen Server gegönnt, :-) ... und bin gleich mal in die Vollen.
    Aber, ... ich glaube ich bin ein wenig zu weit raus geschwommen! :oops:


    Der Server ist ein Samba-Server auf Linuxbasis (Ubuntu-Server).
    Eingerichtet habe ich denke ich alles, d.h.,
    - SQL-Server
    - Datenbank eingerichtet
    - usw.


    Wenn ich nun in Imabas eine neue SQL-Datenbank einrichten will kommt folgende Fehlermeldung ... (siehe Grafikanhang!)


    Ich habe jetzt schon so einiges versucht, ... mit anderen Hostnamen und Benutzern, ... ohne Erfolg.
    Auch habe ich hier im Forum und auch in anderen Foren gesucht, aber fündig bin ich nicht so richtig geworden.


    Noch kurz ein paar Daten zu meinem Netzwerk,
    - Samba-Server (Linux, Ubuntu-Server, ... ist mein alter Rechner)
    - Clients, Linux wie auch WinXP
    - das Netzwerk ist mit festen IP-Adressen eingerichtet


    Der gegenseitige Zugriff auf die freigegebenen Bereiche funktioniert tadellos!


    Für mich ist nicht ganz klar welche Verbindungsdaten ich eingeben muß!
    Und vielleicht fehlt mir als SQL-Neuling noch das nötige Hintergrundwissen!
    Könnten mir da die SQL-Profis hier vielleicht einen Tip geben?
    Vielen Dank dafür!


    @ Kai: Ich weiß daß du nicht gerne einen Support für andere Programme gibts (hast du in deinem Workshop "SQL Datenbankerstellung" geschrieben, ... aber ... bite bitte

    Kai? :schein:


    Wie iss dat nu??? ... Grillen find ich auch nicht ganz so schlecht!! :e010:


    Nach längerer Abstinenz meldet sich der Urheber auch mal wieder.
    Ich mach jetzt mal wieder ne Auffrischungsanfrage in die Runde!
    - wer hätte denn Interesse?
    - wer würde denn auch kommen?
    - wie weit würdet ihr denn fahren können / wollen?
    - Termin?


    Fragen über Fragen! Lasst mal hören!

    Moin an Alle,

    jetzt habe ich doch tatsächlich schon 100 (und hoffentlich porduktive) Beiträge!
    Danke an alle die mir immernoch antworten! :-)

    Uhhiiii, ... jetzt bin ich ja schon "Professional"!


    Was mir noch passiert ist, das ich mit Irfan mir einen Tag ausgesucht habe, den Imabas dann nicht gelesen hat. Vielleicht soetwas? Findest Du Deinen TAgbeim Importieren in der Liste?MiRu


    Genau, ... das meine ich! Ich finde meinen ausgesuchten Tag nicht in der Liste.
    Imabas kann wohl nicht alle bereitgestellten Exifdaten einlesen.

    Hallo Kai, Hallo User,

    ich bin mal wieder am "experimentieren"! :-)


    Also folgendes!
    Man kann ja inzwischen so einige exif Daten importieren. Über Datenbank - Administrator - importieren kann man im Reiter "EXIF" 6x vorgewählte Daten anwählen, aber auch über Tags, noch andere hinzufügen. Also schaue ich nach der genauen Bezeichnung und trage den Tag ein.
    Über den Button "hinzufügen" öffne ich mein ausgesuchtes Bild, und bekomme dann eine Auswahl diverser Exifdaten, ... :-) ...
    ... nur nicht das welches ich mir vorher als Tag angelegt habe! :cry:
    Woran liegt das?

    Ha, ... das ist jetzt mal ein schönes Teil!


    Und, wenn man jetzt hier noch mit diversen Einträgen die Sortierung beim Einpflegen in IMABAS steuern könnte, ... daß wär was feines! :-)


    oder geht das etwa schon irgendwie?

    Hallo,


    wie wärs wenn Du vorher mit dem PDFCreator @home PDFs erzeugts und dann auf Arbeit in einem Rutsch durch den Drucker jagst. Oder gibts da Beschänkungen was Datenträger mitbringen angeht ?


    Ich werd's vielleicht noch besser machen! :nicken:
    Ich werd vielleicht ein schönes PDF machen mit verlinktem Inhaltsverzeichnis usw., und werd Kai fragen ob er das brauchen kann!!! :grin: