Tastaturkürzel funktionieren nicht

  • In der Browser-Ansicht funktioniert der Aufruf der Personen und Tiere über die Tastaturkürzel Ctrl-Alt-P und Ctrl-Alt-T nicht mehr. Als Workaround muss nach dem Markieren des Bildes der Aufruf über den Punkt Personen im Ribbon erfolgen.

    Der Link zeigt einen Ausschnitt aus Imabas mit einem markierten Bild, bei welchem der Aufruf mit Ctrl-Alt-P oder Ctrl-Alt-T ein Fenster öffnen müsste.

    [Blocked Image: http://www.family-leu.ch/imabas/imabas10_ctrl-alt-p_funktioniert-nicht.jpg]

    Der Aufruf der Objekte mit Ctrl-Alt-O hingegen funktioniert.

    Wird das Bild geöffnet und dann die Tastaturkürzel Ctrl-Alt-P oder Ctrl-Alt-T betätigt funktioniert es weiterhin. Doch ein Öffnen des Bildes ist nicht immer notwendig.

    Ich kann nicht mehr mit Sicherheit sagen, mit welcher der vorherigen Versionen es einwandfrei funktionierte, vermutlich geht es ab Build 2260 nicht mehr.

    Ich verwende Imabas 10.0.10 (Build 2260) auf moderner Hardware mit Windows 7 Ultimate Deutsch und 8 GB RAM. Als Datenbank verwende ich einen SQL Server 2008 R2 (Version 10.50.2500.0) auf Windows Server 2003 in der lokalen Domäne.

  • Hallo Kai

    In der Standardansicht funktionieren alle Tastaturkürzel. Wechsle ich auf ein "eigenes" Layout (siehe Bildschirmfoto) funktioniert zwar Ctrl-Alt-O für Objekte, aber für Personen und Tiere nicht. Verdeckte Fenster sehe ich keine.

  • Hallo Kai

    Bei den beiden selber definierten Layouts ist links der Explorer angeordnet, in der Mitte mit 6 oder 15 Bildern der Browser und rechts die zugeordneten Personen.
    [INDENT]
    [/INDENT]Die beiden "Fenster" 'Browser' und 'Zugeordnete Personen' habe ich auf die passende Grösse gezogen und das Layout gespeichert. Im Hintergrund sind keine Fenster unsichtbar vorhanden.

    Weitere Versuche:
    Habe noch mehr damit gespielt und folgenden Unterschied festgestellt: Die Tastaturkürzel für Themen, Objekte, Personen, Hardware, Tiere und Standort funktionieren nicht, wenn man ein Bild markiert. Ruft man hingegen über das Symbol im Band eine der Eigenschaften auf und schliesst den Dialog wieder, funktionieren anschliessend die Tastaturkürzel, aber nur bis zum nächsten expliziten Markieren eines Bildes. Der Unterschied beim Markieren von Bildern ist farblich erkennbar, siehe nachfolgende Bildschirmfotos.



    Was ist der Unterschied der unterschiedlichen "selektierten" Bilder? Ich beschreib dies mal mit "markiert" und "noch ausgewählt".

    • wenn "markiert" sieht es so aus und die Tastaturkürzel funktionieren nicht:


    [INDENT]
    [/INDENT]

    • wenn "nicht mehr selektiert", aber nach Schliessen des Eigenschaftenfenster irgendwie noch ausgewählt, sieht es so aus und die Tastaturkürzel funktionieren:


    [INDENT]
    [/INDENT]Weshalb wird ein Foto nach dem Schliessen eines Eigenschaften-Dialogs nicht mehr gleichermassen markiert angezeigt?