Problem beim Bild löschen mit einer MySQL Datenbank

  • Hallo Kai,
    ich setzte Imabas mit zwei Lizenzen auf einem Qnap NAS mit einer MYSQL Datenbank ein. Angelegt habe ich die DB mit PhpMyAdmin.
    Beim erzeugen der Datenbankstruktur durch Imabas sieht alles normal aus, es kommen keinerlei Fehlermeldungen. Das erzeugen von Volumes und das Importieren von Bilder funktioniert ohne Probleme.


    Aber beim löschen eines oder mehrerer Bilder kommt die angehängte Fehlermeldung. :?:
    Startet man Imabas nach einem solchen Löschversuch neu, kommt eine Meldung, das "alle Lizenzen verbraucht sind" oder so ähnlich, dabei will in diesen Augenblick nur ein Benutzer auf die DB zugreifen. :c090:


    Ich setze ein:
    Imabas 8.1
    MySQL 5.1
    phpMyAdmin 3.2
    QNAP TS 859 NAS
    1 PC unter Win XP SP3
    1 Notebook unter Win 7 64 bit


    Ein Idee was das sein kann ?


    Gruß
    Paul

  • Hallo Paul,
    habe danach mal im Internet gesucht und dazu diese beiden Themen gefunden:


    http://forums.admon.org/databa…b-not-safe-statement.html


    http://dev.mysql.com/doc/refma…n/binary-log-setting.html


    Wenn ich bei mir auf meinem NAS schaue ist die Variable binlog_format gar nicht gesetzt. Versuch die mal zu entfernen oder wie im ersten Thema auf MIXED zu setzen.


    Zu den Verbindungen: Die kannst du unter Datenbank > Verbindungen löschen... Wenn beide verbraucht sind, Imabas im Administrator-Mode starten...

  • Hall Kai,
    jep, das war´s :smile2:


    vielen Dank für prompte Hilfe :schein:!!


    Variable auf 'MIXED' gesetzt und schon geht´s.
    Ich hätte nicht gedacht, das diese Meldung etwas mit den mySQL-Variablen zu tun hat, aber ich bin auch kein DB Experte.


    Gruß und Dank
    Paul


    P.S. Die Verbindungen löschen ging auch nicht, da vermutlich alle Löschvorgänge durch die falsch gesetzte Variable blokiert waren.