Imabas auf zweitem Rechner installieren!

  • Hallo Foriker,

    ich habe Zuhause ein kleines Netzwerk, Hauptrechner und Laptop, zusammengeführt mit WinXP und freigegebenen Ordnern.
    Auf dem Hauptrechner ist Imabas und die Datenbank installiert.
    Könnte ich nun auf meinem Laptop auch Imabas installieren und die Datenbank vom Hauptrechner einbinden?

  • Hallo Martin,
    ja das geht aber nur über einen separaten SQL-Server, oder du legst eine Kopie die der FDB-Datei auf das Notebook und öffnest diese. Letzteres sollte sich dann allerdings auf gucken beschränken da du die beiden Datenbanken nicht synchronisieren kannst.


    Erstes geht mit einen MySQL-Server oder wenn du nur gelegentlich das Notebook verwendest mit einem Firebird 1.5!!! Server. Dieser hat den Vorteil das du die FDB-Datei lokal direkt mit Imabas oder mit dem Firebird-Server öffnen kannst.


    Folgendes dann:

    • Die FDB-Datei liegt in e:\data\imabas\datenbank.fdb
    • Mit Imabas kanns du diese Datei direkt öffnen

    oder:

    • Du installierst einen Firebird-Server und legst in der alias.conf eine Datenbank an, z.B. data = e:\data\imabas\datenbank.fdb
    • Du startest den Firebird-Server
    • Du erzeugst in Imabas unter Datenbank/Firebird/Verbindungsdatei erzeugen eine Verbindungsdatei
    • Diese Verbindungsdatei kannst du vom PC und vom Notebook aus öffnen
    • Die Datenbank wird dann vom Firebird-Server verwaltet
    • Zwei gleichzeitige Verbindungen erfordern auch zwei Lizenzen
    • Last but not Least: Du solltest dir Gedanken um die Netzlaufwerke machen und diese sauber mit Volumes abbilden

    Wenn du noch weitere Hilfe brauchst, meld dich einfach nochmal :-P

  • Hallo Kai,

    danke für die schnelle Antwort, ... auf dich ist halt Verlass!

    Wenn ich also alles richtig verstanden habe (von DB's habe ich nicht so viel Ahnung) bräuchte ich für die Firebird - Version, 2 Lizenzen. OK, ... aber das wollte ich nicht.:oops:

    Die andere Variante mit der Kopie der DB auf mein Notebook ist eigentlich eine sehr gute Idee. :-)
    Dann hätte ich gleichzeitig noch eine Sicherheitskopie, und zum Gucken war's ja auch gedacht.

    Gut, dann kann ich also Imabas zusätzlich auf meinem Laptop installieren, ... mit dem selben Lizenzschlüssel???
    Und noch ne Frage, ... würde der Export eines Bildes dann von Laptop aus funktionieren?

  • Hallo Martin,
    eine zweite Lizenz brauchst du nur wenn zwei gleichzeitig arbeiten wollen, Imabas hat eine konkurrierende Lizenz, und den Firebird-Server gibt es auch für Lau :e010:


    Alles würde vom Laptop aus funktionieren, du musst nur darauf achten das die Pfade stimmen. Wenn du Bilder auf deinem PC auf Laufwerk E: liegen hast und es das auf dem Laptop nicht, findet Imabas natürlich die Bilder nicht.


    Lösungen:

    • Netzlaufwerke, also beiden Rechnern muss es ein Laufwerk X: geben, auf dem PC per subst und auf dem Laptop per Laufwerksmapping.
    • Volumes mit UNC-Pfaden, also E: ist im Volume als \\pc\e$ definiert

    Prinzipiell solltest du dich generell mit den Volumes auseinander setzen, die ersparen dir dabei sehr viel Kopfzerbrechen :-P


    Zur Lizenz: Prinzipiell ist Imabas dafür ausgelegt zur parallelen Benutzung einer Datenbank, und das geht nur mit mehreren Lizenzen. Lokale interne Datenbank lassen sich generell nur einmal öffnen. Andersherum kannst du natürlich so viele Datenbanken erzeugen wie du willst, von mir aus für jedes Bildes eine :shock:


    Das du den Schlüssel natürlich auch für mehrere Datenbanken auf mehreren Rechnern verwenden kannst, ist eigentlich nicht in Ordnung, aber so was will ich im privaten Bereich gar nicht erst verfolgen bzw. kontrollieren und verhindern. Schon gar nicht wenn eine Privatperson so ehrlich ist und keine illegale Kopie verwendet :-)

  • Hallo Kai,


    ups, ... das mit der Lizenz war nicht meine Absicht.
    Dank deinem Verständnis bin ich aber nochmal mit einem blauen Auge davon gekommen.:e030:
    Desweiteren werden ich nie gleichzeitig an der Datenbank arbeiten.


    Ok, soweit sogut.
    Ich habe nun also Imabas auf dem Laptop installiert, habe die db auf das Laptop kopiert, in ein Laufwerk mit dem selben Buchstaben (bei mir ist das F:, ... F wie Foto :-)). Und das Viewing funktioniert. :smile2:


    Ein innerer Ergeiz sagt mir aber, ... das andere soll auch gehen.
    Aber das blicke ich nicht ... :c090:


    Könntest du mir das nochmals, vielleicht mit anderen Worten ( ... dem PC per subst und auf dem Laptop per Laufwerksmapping ... versteh ich nicht).
    Und das (... Volumes mit UNC-Pfaden, also E: ist im Volume als \\pc\e$ definiert ... ) versteh ich auch nicht.
    Und was du mit den Volume's meinst, ... sind das vielleicht die Volume's in der Datenbank oder die Laufwerke???
    Du merkst vielleicht, hier ist ein Laie am Werk.

  • Hallo Kai,


    ich bins nochmal.
    Ich habe gerade das Handbuch nochmals durchgelesen.
    Ich brauche also den Firebird, ... welchen denn?
    Da gibts gar viele! Selbst den 1.5 gibt in verschiedenen Varianten.


    Gruß Martin

  • hallo Kai,


    also nachmal ich!
    Folgende Schritte habe ich ausgeführt.


    1. Firebird installiert ( Firebird-1.5.4.4910-0-Win32.exe , download von http://www.firebirdsql.org/ind…p=files&id=engine_154
    2. die Datei aliases.conf in einem Texteditor geöffnet und verändert in: IMABAS_001 = F:\Imabas\Datenbank\IMABAS_001.FDB (das ist mein Pfad auf welcher meine DB liegt.
    3. Firebird gestartet
    4. Über Datenbank-Firebird-Verbindungsdatei erzeugen folgende Daten eingegeben:
    Hostname: localhost
    Datenbank: IMABAS_001 = F:\Imabas\Datenbank\IMABAS_001.FDB
    Benutzername: admin (Loginname von Windows)
    Passwort: ****** (Passwort von Windows)


    Wobei ich mir bei Benutzername und Passwort nicht sicher bin welche Daten da rein kommen!


    Und bestätigt mit "testen" --> Fehlermeldung!!! :cry:


    Wo liegt das Problem?

  • Hallo Martin,
    anhand der Doku würde ich nicht den Guardian starten und den Server als Anwendung starten, so oft wirst du den ja nicht brauchen, oder? Ansonsten als Dienst...


    Auch würde ich alle Häkchen auf Seite 7 wegmachen.


    Ich hoffe nicht das das Kennwort des SYSDBA geändert hast, wie es in der Anleitung steht?


    Und: Die FDB-Datei darf während des Zugriffs nicht von Imabas geöffnet sein, diese Datei darf immer nur ein Server geöffnet haben, extern oder intern.


    Was dabei?

  • Hallo Kai,

    ok, ich werde alle Häckchen abschalten, und ... wie jetzt?
    Firbird Server starten als: ... Anwendung oder als Dienst???
    Kommt in deinem Satz nicht ganz klar rüber! Ich denke aber du meinst als Anwendung! :?:

    Nein, das Kennwort habe ich nicht verändert!!!

    Und nur einmal öffnen, ist klar!

    Beim lesen übers WE ist mir ein Satz aufgefallen. http://www.pamsf.info/showthread.php?t=562
    In dem 4. Beitrag (von Dir) fragst du ... "ist f: bei dir ein Netzlaufwerk?" ...
    Was meinst du damit?

    Und dann noch ne Frage. Wo muß ich denn Firebird installieren? Auf C: von "Matz"?

    Zur Erinnerung!
    1x PC (der heißt "Matz"),
    1x Laptop (der heißt "Fritz"),
    das Netzlaufwerk von "Fritz" ist in der Ordnerstruktur von "Matz" als Y: bezeichnet,
    Imabas DB liegt auf Festplatte (Partition F:) von "Matz",
    ... äähhhmm ja so ist das bei mir! :oops:

    Ich danke dir übrigens für deine Geduld mit mir! :-)

  • Hallo Martin,
    also den Firebird-Server installierst du auf dem Rechner der auch die Bilder hat, also auf Matz. Da du den ja nicht ständig brauchst würde ich den als Anwendung starten, es sei denn deine Maschine ist stark genug, dann kannst ihn auch ständig mitlaufen lassen.


    Server z.B. auf "Matz": c:\programme\firebird


    Deine Datenbank (FDB) befindet sich auf Laufwerk F: dort im Verzeichnis Imabas (Annahme), dann trägst du in die Datei c:\programme\firebird\aliases.conf die Zeile imabas = f:\imabas\imabas.fdb ein.


    Wenn deine Bilder auch alle auf F: sind, solltest du versuchen auf dem Laptop das Laufwerk F: auch als F: zu mappen, und nicht als Y:, es sei denn du arbeitest bereits mit Volumes.
    (siehe dazu diesen Threas [thread]1006[/thread])


    Nach dem den Server gestartet hast, öffnest du Imabas, das wird jetzt wahrscheinlich versuche auch die FDB-Datei zu öffnen und sollte eine Fehlermeldung bekommen, ist dem so, ist das ein gutes Zeichen das der Server sie bereits in Beschlag genommen hat :-P


    Dann legst du wie weiter oben eine Verbindungsdatei an, die du als FBC-Datei im Verzeichnis der FDB-Datei speicherst!!! Diese kannst du dann als Datenbank öffnen wenn der Firebird-Server läuft. Wichtig ist das als Host der Hostname von Matz angegeben wird, denn dort sucht der Fritz den Firebird-Server!


    Wenn du nun auf dem Laptop das Mapping entsprechend geändert hast, kannst du von dort aus auch die FBC-Datei öffnen.


    Um mit Y: als Mapping zu arbeiten musst du Volumes verwenden!

  • Hallo Kai,


    :cry: ... ist gebe auf ... :cry:... ich bin völlig entnert und ratlos !!!


    ist normalerweise nicht meine Art, ... ich bin aber sowas von frustriert!


    Ich habe alles so gemacht wie "befohlen", ... aber nix geht!


    Du schreibst, daß sich Imabas beschwert wenn ich das Programm öffne, ... tut Imabas aber nicht! Öffnet mir ohne zu murren die Datenbank, obwohl ich der Firebird vorher gestartet habe und die Datenbank eigentlich "besetzt" sein müßte!
    Ein Anlegen einer Verbindungsdatei mit anschließendem Verbindungsversuch scheitern kläglich (ein Test vorab mit dem Testbutton geht ja schon nicht)!


    Ich hab keine Erklärung mehr! ... Mmmmhhh ... vielleicht nur dies ... muß ich den die Groß - Kleinschreibung beachten? Kann aber auch nicht sein, habe ich eigentlich peinlichst genau beachtet.
    Das mit dem Mapping habe ich auch gelöst ... Y: ist jetzt F: ...


    Ich weiß einfach nicht mehr weiter!


    Niedergeschlagene Grüße

  • Aaaalso, ich habe das ganze jetzt mal hier auf einer Testmaschine gemacht:


    Geladen habe ich: Firebird-1.5.5.4926-3_win32.zip von der firebirdsql.org Seite
    Dann auf Laufwerk c: einen Ordner Firebird angelegt und das Archiv direkt dahin entpackt...


    Dann in der Datei c:\firebird\aliases.conf den Eintrag:[INDENT]kai = e:\data\.....\kai.fdb
    [/INDENT]gemacht.


    Dann einen Command-Prompt geöffnet und c:\firebird\bin\fbserver -a aufgerufen, es erscheint das Firebird-Symbol rechts unten neben der Uhr. Du kannst dir dafür auch eine Verknüpfung anlegen, wichtig ist das du den Parameter "-a" angibst... Beenden kannst du den Server, in dem du das Symbol mit Rechts anklickst und Shutdown wählst...


    Dann in Imabas rein: Datenbank / Firebird / Verbindungsdatei erzeugen aufgerufen, als Werte dann

    Code
    1. Host = myhostname << Bei dir MATZ !?
    2. Datenbank = kai << Aus dem Alias!
    3. Benutzer = sysdba
    4. Kennwort = masterkey

    eingetragen.


    Testen anklicken, OK!


    Dann speichern als e:\data\.....\kai.fbc und diese dann unter Datei / Öffnen geöffnet, und geht...


    Versuch das mal.

  • Hallo Kai,

    zuerst mal noch angenehme und nachträgliche Weihnachtsgrüße!

    Und ... :c090: ... ich bin immer noch nicht weiter gekommen!!!

    Irgendetwas stimmt noch nicht!
    Wie gesagt, ... eigentlich alles so gemacht wie du gesagt hast!

    Ich habe in den letzten Tagen so ziemlich alles durchgelesen was mit diesem Thema auch nur annähernd zusammenhängt. Es gibt da ein paar Sachen die mir nicht ganz klar sind!
    Aber gut, ... fange ich mal an!
    1. Du sagst daß Imabas meckert wenn der Firebird läuft und Imabas auf die Datenbank zugreifen will! Bei mir funktioniert dies nicht!
    Imabas öffnet die DB obwohl der Firebird läuft, ... folglich greift der Firebird nicht auf die DB zu, ... folglich stimmt die Pfadzuordnung im aliases.conf nicht!
    Zustimmung, oder was meinst du?
    Und ... was läuft da verkehrt?

    Ich wollte eigentlich mit 2. ... 3. ... weiter machen, ... aber mal langsam denke ich!
    Ich will dem Fehler grundlegen auf die Pelle rücken. :a015:

  • Fangen wir dann mal Stück für Stück an:
    Das Archiv oben genannte Archiv hast du geladen, und in den von mir genannten Ordner entpackt?


    Kein Witz, mach mal einen Screenshot von dem Ordner, so das ich hier sicher sein kann das das korrekt ist, nur so kommen wir weiter!


    Wenn du von der Kommandozeile oben genannnten Befehl absetzt (fbserver...) hast du rechts unten bei der Uhr ein Firebird-Symbol?